PAT A 1067 Sort with Swap(0,*)

Given any permutation of the numbers {0, 1, 2,…, N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}\ Swap(0, 3) => {4, 1, 2, 3, 0}\ Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=10^5^) followed by a permutation sequence of {0, 1, …, N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10 3 5 7 2 6 4 9 0 8 1

Sample Output:

9
交换位置下标计算总次数,理的晴神代码。。处理0在0号的时候要小心,找第一个不在自己位置上的和0交换,k的数值要一直往后累加,不能每次进去都从第一个找,不然会超时

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 100010;
int main() {
    int n, num;
    int pos[maxn];
    scanf("%d", &n);
    int left = n-1;
    for (int i = 0; i < n; i++) {
        scanf("%d", &num);
        pos[num] = i;
        if (num == i && num != 0) left--;
    }
    int ans = 0,k=1;
    while (left--) {
        if (pos[0] == 0) {
            while (k < n) {
                if (pos[k] != k) {
                    swap(pos[0], pos[k]);
                    ans++;
                    break;
                }
                k++;
            }
        }
        while (pos[0] != 0) {
            swap(pos[0], pos[pos[0]]);
            ans++;
        }
    }
    printf("%d\n", ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/joah_ge/article/details/80701964