简单DP

Description

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 
 

 7 

 3   8 

 8   1   0 

 2   7   4   4 

 4   5   2   6   5

Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample: 
 

 7 
 *

 3   8 
 *

 8   1   0 
 *

 2   7   4   4 
     *

 4   5   2   6   5

The highest score is achievable by traversing the cows as shown above.

题意:每次向下或者向右下走,求最大和

分析:正向:每步来源于上方或者左上方,dp[i][j];

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
#define N 0x3f3f3f3f
using namespace std;
int map[355][355];
int mapp[355][355];
int n;
int dp(int x,int y)
{
	if(x==n)
	{
		mapp[x][y]=map[x][y];
		return mapp[x][y];
	}
	if(mapp[x][y]>=0)
	{
		return mapp[x][y];
	}
	mapp[x][y]=map[x][y]+max(dp(x+1,y),dp(x+1,y+1));//递归式搜索 找出 下一行 最大值 
	return mapp[x][y];
}
int main()
{
	cin>>n;
	memset(mapp,-1,sizeof(mapp));
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<=i;j++)
		{
			cin>>map[i][j];
		}
	}
	dp(0,0);
	cout<<mapp[0][0]<<endl;
	return 0; 
} 

猜你喜欢

转载自blog.csdn.net/henucm/article/details/81079356