1067 Sort with Swap(0,*) (25)

Given any permutation of the numbers {0, 1, 2,..., N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}\ Swap(0, 3) => {4, 1, 2, 3, 0}\ Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=10^5^) followed by a permutation sequence of {0, 1, ..., N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10 3 5 7 2 6 4 9 0 8 1

Sample Output:

9

思路:

出一个n个数的序列,数字为0~n-1的乱序,每次用两两交换的方式而且只能用0和另一个数交换,使序列变成有序的,问最少需要多少步骤。

1. 0不在0位,那么0如果在第i位,而第i位本应该是i,就应该把0和i数字所在的位置交换。
2. 如果0在0位,而且整个序列到现在还不是有序的,那就把0和第一个序列没在该在的位置上的数字交换。

3.避免多次for循环数组,用v[i]=j代表i数字现在在j位上。

4.用index记录第一个不在位置上的数

C++:

#include <cstdio>
#include <vector>
using namespace std;
int main() {
	int n, num, cnt = 0, ans = 0, index = 1;
	scanf("%d", &n);
	vector<int> v(n);
	for(int i = 0; i < n; i++) {
		scanf("%d", &num);
		v[num] = i;
		if(num != i && num != 0) cnt++;//记录非0数、不在该在的位置上的数
	}
	while(cnt > 0) {
		if(v[0] == 0) {//当0在0位置
			while(index < n) {//index之前的数都在该在的位置上
				if(v[index] != index) {//交换0和第一个不在该在位置上的数
					swap(v[index], v[0]);
					ans++;//交换次数+1
					break;
				}
				index++;
			}
		}
		while(v[0] != 0) {
			swap(v[v[0]], v[0]);//交换0所在位置上的数
			ans++;//交换次数+1
			cnt--;//不在位置上的数-1
		}
	}
	printf("%d", ans);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ysq96/article/details/81148491