poj 2155

Matrix

Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 32374   Accepted: 11737

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

扫描二维码关注公众号,回复: 2444340 查看本文章

POJ Monthly,Lou Tiancheng

二维线段树单点更新 区间查询,之前做过一遍,但是并没有真正的搞懂。

这里一片论文中很清楚的讲了为什么 sum(x1,  y1) 就是答案。

浅谈信息学竞赛中的“0”和“1”

代码: 

#include<stdio.h>
#include<iostream>
#include<string.h>

using namespace std;
const int N =1005;
int sum[N][N];

int lowbit(int x)
{
    return x&(-x);
}

void add(int x,int y)
{
    while(x<N)
    {
        int tmpy=y;
        while(tmpy<N)
        {
            sum[x][tmpy]+=1;
            tmpy+=lowbit(tmpy);
        }
        x+=lowbit(x);
    }
    return ;
}

int getsum(int x,int y)
{
    int res=0;
    while(x>0)
    {
        int tmpy=y;
        while(tmpy>0){
            res+=sum[x][tmpy];
            tmpy-=lowbit(tmpy);
        }
        x-=lowbit(x);
    }
    return res;
}

void update(int x1,int yy1,int x2,int y2)
{
    add(x1,yy1);
    add(x1,y2+1);
    add(x2+1,yy1);
    add(x2+1,y2+1);
}

int n,q;
char op[5];

int main()
{
    int T;
    scanf("%d",&T);
    int x1,yy1,x2,y2;
    while(T--){
        memset(sum,0,sizeof(sum));
        scanf("%d %d",&n,&q);
        while(q--)
        {
            scanf("%s",op);
            if(op[0]=='C'){
                scanf("%d %d %d %d",&x1,&yy1,&x2,&y2);
                update(x1,yy1,x2,y2);
            }
            else{
                scanf("%d %d",&x1,&yy1);
                int ans=getsum(x1,yy1);
                cout<<ans%2<<endl;
            }
        }
        if(T!=0) printf("\n");
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/yjt9299/article/details/81154090