HDoj 2032 杨辉三角

Problem Description
还记得中学时候学过的杨辉三角吗?具体的定义这里不再描述,你可以参考以下的图形:
1
1 1
1 2 1
1 3 3 1
1 4 6 4 1
1 5 10 10 5 1
 
Input
输入数据包含多个测试实例,每个测试实例的输入只包含一个正整数n(1<=n<=30),表示将要输出的杨辉三角的层数。
 
Output
对应于每一个输入,请输出相应层数的杨辉三角,每一层的整数之间用一个空格隔开,每一个杨辉三角后面加一个空行。
 
Sample Input
2 3
 
Sample Output
1 1 1 1 1 1 1 2 1
 
Author
lcy
 
Source
 
Recommend
lcy   |   We have carefully selected several similar problems for you:   2033  2034  2035  2040  2041 
 
 
 
 
C语言代码如下:
#include<stdio.h>
#include<malloc.h>
int main()
{
    int n=0;
    while(scanf("%d",&n)!=EOF)
    {
        int **a=(int **)malloc(sizeof(int*)*n);
        for(int i=0;i<n;i++)
            a[i]=(int *)malloc(sizeof(int)*(i+1));
        for(int i=0;i<n;i++)
            for(int j=0;j<i+1;j++)
            {
                if(j==0||j==i)
                    a[i][j]=1;
                else
                    a[i][j]=a[i-1][j-1]+a[i-1][j];
            }


        for(int i=0;i<n;i++)
        {
            for(int j=0;j<i+1;j++)
            {
                if(j==0)
                    printf("%d",a[i][j]);
                else
                    printf(" %d",a[i][j]);
            }
            printf("\n");
        }
        printf("\n");
    }
}

猜你喜欢

转载自www.cnblogs.com/wzmm/p/12591873.html