[Functions]D. Liang 5.13 Summing series.c

***Description
Computing series using the following formula:

m(n)=1/2+2/3++n/n+1

Input
A positive integer n (1 <= n <= 10000)
Output
Series computing by n
(The precision of series should be fixed to 4)
Sample Input

3

Sample Output

1.9167***
//   Date:2020/3/28
//   Author:xiezhg5
#include <stdio.h>
int main(void)
{
	int n;
	int i,a,b;
	float sum=0;
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		a=i;
		b=a+1;
		sum=sum+1.0*a/b;
	}
	printf("%.4f\n",sum);
	return 0;
}

Only float type can be used to define sum, and double can cause the following situations:
在这里插入图片描述

发布了131 篇原创文章 · 获赞 94 · 访问量 2939

猜你喜欢

转载自blog.csdn.net/qq_45645641/article/details/105169214