uva_1585_Score

There is anobjective test result such as ``OOXXOXXOOO". An `O' means a correct answerof a problem and an `X' means a wrong answer. The score of each problem of thistest is calculated by itself and its just previous consecutive `O's only whenthe answer is correct. For example, the score of the 10th problem is 3 that isobtained by itself and its two previous consecutive `O's.

Therefore, the scoreof ``OOXXOXXOOO" is 10 which is calculated by ``1+2+0+0+1+0+0+1+2+3".

You are to write aprogram calculating the scores of test results.

 Input

Your program is toread from standard input. The input consists of T test cases.The number of test cases Tis given in the first line of the input.Each test case starts with a line containing a string composed by `O' and `X' and the length of the string is morethan 0 and less than 80. There is no spaces between `O' and `X'.

 output

Your program is towrite to standard output. Print exactly one line for each test case. The lineis to contain the score of the test case.

The followingshows sample input and output for five test cases.

 sample input 

5

OOXXOXXOOO

OOXXOOXXOO

OXOXOXOXOXOXOX

OOOOOOOOOO

OOOOXOOOOXOOOOX

 sample output

10

9

7

55

30

#define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int main()
{
	int i, n;
	scanf("%d", &n);
	for (i = 1; i <= n; i++)
	{
		char s[85], c[85] = { 0 };
		int j, len, sum = 0;
		scanf("%s", s);
		len = strlen(s);
		for (j = 0; j<len; j++)
		{
			if (j == 0)
			{
				if (s[j] == 'O')
					c[j] = 1;
				else
					c[j] = 0;
			}
			else
			{
				if (s[j] == 'O')
					c[j] = c[j - 1] + 1;
				else
					c[j] = 0;
			}
		}
		for (j = 0; j<len; j++)
		{
			sum = sum + c[j];
		}
		printf("%d\n", sum);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/shenziheng1/article/details/80168787