dp-牛奶的最大加仑数

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0…N-1) so that she produces as much milk as possible.
Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.
Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

  Input
  
   * Line 1: Three space-separated integers: N, M, and R
  • Lines 2…M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi
    Output

     * Line 1: The maximum number of gallons of milk that Bessie can product in the N hours
    

Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output
43
拿题思想:首先这是一个求在一段时间内所挤得牛奶最大加仑数,这是一个求最值问题,符合使用动态规划的要求;如何找到状态呢?这里因该是将时间作为状态,应为在连续的时间内,他不是在挤牛奶就是在休息;所以用dp[i]来表示在挤完i时间段的最大挤奶量。
遇到问题:如何找到状态转移方程?首现在挤了一次那么就得消耗掉挤牛奶得时间和休息的时间,所以不妨将每个时间段的结束时间用结束时间加休息时间来表达;那么状态转移方程就如以下代码实现:

for(int i=0;i<m;i++)
{
     dp[i]=a[i].v;      //从最早的那个时间开始;
     for(int j=0;j<i;j++)
     {
         if(a[j].j<=a[i].k)      //如果当a[j]的结束时间小于等于a[i]的开时间,那么就可以挤a[i]时间段的奶;
            dp[i]=max(dp[j]+a[i].v,dp[i]);     
     }
}

最终解题思路
1)定义一个结构体数组储存每个时间段的挤奶开始时间和结束时间和效率;
2)将结构体数组以开始时间从小到大进行排序;
3)利用状态转移方程求出以i结束的时间段的dp[i];
4)最后找出最大值ans;

#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
struct node
{
    int k,j,v;
}a[1001];
bool cmp(node b,node c)
{
    return b.k<c.k;
}
int main()
{
    int dp[1001];
    int n,m,r,ans;
    cin>>n>>m>>r;
    for(int i=0;i<m;i++)
        {
            cin>>a[i].k>>a[i].j>>a[i].v;
            a[i].j+=r;
        }
    sort(a,a+m,cmp);
    for(int i=0;i<m;i++)
        {
            dp[i]=a[i].v;
            for(int j=0;j<i;j++)
                {
                    if(a[j].j<=a[i].k)
                        dp[i]=max(dp[j]+a[i].v,dp[i]);
                }
        }
    ans=dp[0];
    for(int i=1;i<m;i++)
        ans=max(ans,dp[i]);
    cout<<ans<<endl;
    return 0;
}
发布了12 篇原创文章 · 获赞 0 · 访问量 131

猜你喜欢

转载自blog.csdn.net/weixin_46446866/article/details/105205551