PAT 甲级练习 1013

1013. Battle Over Cities

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input

3 2 3
1 2
1 3
1 2 3

Sample Output

1
0
0

代码如下:

#include <iostream>
#include <vector>
#include <iterator>

using namespace std;

struct Road{
    int ct1, ct2;
    Road(){}
    Road(int a, int b):ct1(a), ct2(b) {}
};

int ancestor(vector<int> &father, int ct)
{
    if(father[ct] == ct)    return ct;
    else    return ancestor(father, father[ct]);
}

void Union(vector<int> &father, vector<int> &size, Road &rd)
{
    int ancest_a = ancestor(father, rd.ct1), ancest_b = ancestor(father, rd.ct2);
    if(ancest_a == ancest_b)    return;
    if(size[ancest_a] > size[ancest_b]){
        father[ancest_b] = ancest_a;
        size[ancest_a] += size[ancest_b];
    }else{
        father[ancest_a] = ancest_b;
        size[ancest_b] += size[ancest_a];
    }
}

int main()
{
    //read 1-st line
    int N, M , K;
    cin >> N >> M >> K;
    //construct matrix
    vector<Road> road;
    int ct1, ct2;
    for(int i=0; i<M; ++i){
        cin >> ct1 >> ct2;
        road.push_back(Road(ct1, ct2));
    }

    //read concerned city and processing
    int ct_war;
    vector<int> father(N+1), size(N+1);
    for(int i=0; i<K; ++i){
        cin >> ct_war;
        //initialize
        vector<int> father(N+1), size(N+1);
        for(int j=1; j<N+1; ++j){
            father[j] = j;
            size[j] = 1;
        }
        //processing
        for(int rd=0; rd<M; ++rd){
            if(road[rd].ct1 == ct_war || road[rd].ct2 == ct_war)    continue;
            Union(father, size, road[rd]);
        }
        //print
        int cnt = 0;
        for(int j=1; j<N+1; ++j)
            if(father[j] == j && j != ct_war) cnt++;
        cout << --cnt << endl;
    }

    return 0;
}

注意:并查集中对根节点的追溯,以及具有相同祖先时不需要Union

猜你喜欢

转载自blog.csdn.net/linlinlin96/article/details/79488298