ZZULIOJ--GJJ的日常之再游戏(去重)

2175: GJJ的日常之再游戏

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 821   Solved: 169

Submit Status Web Board

Description

GJJ和WJJ又开始了游戏,然而由于WJJ太强了,所以GJJ只好靠计谋取胜,而正因为WJJ太强,所以用过一次的计谋便无效了。
GJJ和WJJ一共玩了N场游戏,如果GJJ想要获胜,必须得赢的场数比Wjj多。
问:GJJ能否获胜?

Input

多实例,到文件尾结束
每个样例第一行一个N(1<=N<=50000),表示GJJ每场使用的计谋的数量;
第二行是N个数x,表示计谋的编号(0<=x<=1000000000)。

Output

对于每组样例,如果GJJ获胜输出"Yes";否则输出"No"。

Sample Input

5
1 2 3 4 5
5
1 2 2 2 1

Sample Output

Yes
No


解题思路:本来自己写时写出来了,但是因为看了大佬写的代码,才发现我自己写的好麻烦,~(@^_^@)~
我是先将它们进行从大到小的排序,然后再依次两两比较它们是否相等,最后再加一。代码如下


#include<stdio.h>
#include<algorithm>
using namespace std;
const int maxn=50005;
bool cmp(int a,int b)
{
	return a>b;
}
int main()
{
	int a[maxn];
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int c=0;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);			
		}
		sort(a,a+n,cmp);
		int j=0;
		for(int i=1;i<n;i++)
		{			
			if(a[i]!=a[j])
			{
				c++;
			}
			j++;
		}
		c=c+1;
		if(c>n/2)
		printf("Yes\n");
		else
		printf("No\n");
	}
	return 0;
}


还有一种方法就是排序之后去重之后数组的长度即为GJJ胜利的场数。注意数据范围不能使用set和map。可以使用unique去重,这样就方便多啦。

#include<stdio.h>
#include<algorithm>
using namespace std;
int a[50005];
int main()
{
    int n;
//    freopen("D://2.in","r",stdin);
//    freopen("D://2.out","w",stdout);
    while(scanf("%d",&n)!=-1)
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        int l=unique(a,a+n)-a;
        if(l>n/2)
        {
            puts("Yes");
        }
        else puts("No");
    }
    return 0;
}




猜你喜欢

转载自blog.csdn.net/crystaljy/article/details/77387117