1025 PAT Ranking (25分)【结构体排序】

1025 PAT Ranking (25分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

 解题思路:

简单的结构体排序,定义一个结构体,里面包含准考证号、成绩、考场号、考场排名。

1.首先按照考场排名,同考场的按照成绩排名,相同成绩的则按照准考证号排名。然后统计考场排名。

2.然后按照成绩对全体考生排名。输出的同时并统计总排名。

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;

struct Testee {
	string id;
	int score;
	int location_num;
	int loc_rank;
}testee[30010];

int cmp(Testee a, Testee b)
{
	if (a.score == b.score)
		return a.id < b.id;
	else return a.score > b.score;
}

int cmp2(Testee a, Testee b)
{
	if (a.location_num != b.location_num)
		return a.location_num < b.location_num;
	else if (a.score != b.score)
		return a.score > b.score;
	else return a.id < b.id;
}

int main()
{
	int n;
	cin >> n;
	int cnt = 0;
	for (int i = 1; i <= n; i++)
	{
		int k;
		cin >> k;
		while (k--)
		{
			cin >> testee[cnt].id >> testee[cnt].score;
			testee[cnt].location_num = i;
			cnt++;
		}
	}
	sort(testee, testee + cnt, cmp2);
	int pre_loc = testee[0].location_num;
	int rank = 2;
	testee[0].loc_rank = 1;
	for (int i = 1; i < cnt; i++)
	{
		if (testee[i].location_num == pre_loc)     //如果和前一个同考场
		{
			if (testee[i].score == testee[i - 1].score)
				testee[i].loc_rank = testee[i - 1].loc_rank;
			else testee[i].loc_rank = rank;
			rank++;
			pre_loc = testee[i].location_num;
		}
		else {
			rank = 1;
			testee[i].loc_rank = rank;
			rank++;
			pre_loc = testee[i].location_num;
		}
	}
	sort(testee, testee + cnt, cmp);
	cout << cnt << endl;
	int finrank = 1;
	for (int i = 0; i < cnt; i++)
	{
		if (i != 0 && testee[i].score != testee[i - 1].score)
			finrank = i + 1;
		cout << testee[i].id << " " << finrank << " " << testee[i].location_num << " " << testee[i].loc_rank << endl;
	}
	return 0;
}
发布了119 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/lovecyr/article/details/104696596