1065 A+B and C (64bit) (20分)【简单模拟,溢出判断】

1065 A+B and C (64bit) (20分)

Given three integers A, B and C in [−2​^63​​,2^​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

解题思路:

首先,拿到题目分析数据范围,a,b,c属于[-2^{63} , 2^{63}],并不超过long long的范围,但是,a+b是一定会溢出的。

此时,只要我们知道是正溢出还是负溢出,依然可以解出这道题:

#include<iostream>
using namespace std;
#define ll long long

int main()
{
	int t;
	cin >> t;
	for (int i = 1; i <= t; i++)
	{
		ll a, b, c;
		int flag = 0;
		cin >> a >> b >> c;
		ll add = a + b;
		if (add <= 0 && a > 0 && b > 0)       //正溢出
			flag = 1;
		else if (add >= 0 && a < 0 && b < 0)   //负溢出
			flag = 0;
		else if (add > c)
			flag = 1;
		else flag = 0;
		if (flag)
			cout << "Case #" << i << ": true" << endl;
		else cout<< "Case #" << i << ": false" << endl;
	}
	return 0;
}
发布了119 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/lovecyr/article/details/104616586