HDU - 2056 Rectangles 【几何:矩形重叠】

Description

Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .

Input

Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).

Output

Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.

Sample Input

1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50

Sample Output

1.00
56.25
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cmath>

using namespace std;

int main()
{
    double x1, x2, x3, x4;
    double y1, y2, y3, y4;
    while (scanf("%lf %lf %lf %lf %lf %lf %lf %lf", &x1, &y1, &x2, &y2, &x3, &y3, &x4, &y4) != EOF)
    {
        if (x1 > x2){double temp = x1; x1 = x2; x2 = temp;}
        if (x3 > x4){double temp = x3; x3 = x4; x4 = temp;}
        if (y1 > y2){double temp = y1; y1 = y2; y2 = temp;}
        if (y3 > y4){double temp = y3; y3 = y4; y4 = temp;}
        x1 = max(x1, x3);
        y1 = max(y1, y3);
        x2 = min(x2, x4);
        y2 = min(y2, y4);
        if (x1>x2 || y1>y2)
            printf("0.00\n");
        else
            printf("%.2lf\n", (x2-x1)*(y2-y1));
    }
    return 0;
}
发布了329 篇原创文章 · 获赞 342 · 访问量 17万+

猜你喜欢

转载自blog.csdn.net/Aibiabcheng/article/details/105337012