统计难题(字典树)

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
Output
对于每个提问,给出以该字符串为前缀的单词的数量.
Sample Input
banana
band
bee
absolute
acm

ba
b
band
abc
Sample Output
2
3
1
0

//数组开大开小都会挂 蓝廋

#pragma warning(disable:4996)
#include"iostream"
#include"functional"
#include"algorithm"
#include"cstring"
#include"string.h"
#include"cstdio"
#include"stack"
#include"cmath"
#include"queue"
#include"vector"
#include"map"
typedef long long int ll;
using namespace std;
const ll maxn = 4e5+9;
ll cnt = 0;
ll nex[maxn][26];
ll pp[maxn];
void build(char d)
{
	ll p = 0;
	while (d != '\n')
	{
		int k = d - 'a';
		if (nex[p][k] == 0)
		{
			nex[p][k] = ++cnt;
		}
		p = nex[p][k];
		pp[p]++;
		d = getchar();
	}
}

ll query(string s) {
	ll p = 0;
	for (int i = 0; i < s.size(); i++)
	{
		int k = s[i] - 'a';
		if (nex[p][k] == 0) return 0;
		p = nex[p][k];
	}
	return pp[p];
}
int main() {
	char d;
	cin >> d;
	while (1)
	{
		build(d);
		d=getchar();
		if (d == '\n') break;
	}
	string st;
	while (cin >> st) {
		cout << query(st) << endl;
	}
}
发布了49 篇原创文章 · 获赞 0 · 访问量 660

猜你喜欢

转载自blog.csdn.net/qq_14989799/article/details/105334816