HDU - 5982 Relic Discovery

Description

Recently, paleoanthropologists have found historical remains on an island in the Atlantic Ocean. The most inspiring thing is that they excavated in a magnificent cave and found that it was a huge tomb. Inside the construction,researchers identified a large number of skeletons, and funeral objects including stone axe, livestock bones and murals. Now, all items have been sorted, and they can be divided into N types. After they were checked attentively, you are told that there are AiAi items of the i-th type. Further more, each item of the i-th type requires BiBi million dollars for transportation, analysis, and preservation averagely. As your job, you need to calculate the total expenditure.

Input

The first line of input contains an integer T which is the number of test cases. For each test case, the first line contains an integer N which is the number of types. In the next N lines, the i-th line contains two numbers AiAi and BiBi as described above. All numbers are positive integers and less than 101.

Output

For each case, output one integer, the total expenditure in million dollars.

Sample Input

1
2
1 2
3 4

Sample Output

14
#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
    int n;
    int t;
    int a,b;
    scanf("%d",&t);
    for(int i=0;i<t;i++){
        scanf("%d",&n);
        int sum=0;
        for(int j=0;j<n;j++){
            scanf("%d %d",&a,&b);
            sum+=a*b;
        }
        printf("%d\n",sum);
    }

    return 0;
}
发布了359 篇原创文章 · 获赞 371 · 访问量 18万+

猜你喜欢

转载自blog.csdn.net/Aibiabcheng/article/details/105354358