试题 算法训练 删除数组零元素

从键盘读入n个整数放入数组中,编写函数CompactIntegers,删除数组中所有值为0的元素,其后元素向数组首端移动。注意,CompactIntegers函数需要接受数组及其元素个数作为参数,函数返回值应为删除操作执行后数组的新元素个数。输出删除后数组中元素的个数并依次输出数组元素。
样例输入: (输入格式说明:5为输入数据的个数,3 4 0 0 2 是以空格隔开的5个整数)
5
3 4 0 0 2
样例输出:(输出格式说明:3为非零数据的个数,3 4 2 是以空格隔开的3个非零整数)
3
3 4 2
样例输入:
7
0 0 7 0 0 9 0
样例输出:
2
7 9
样例输入:
3
0 0 0
样例输出:
0

思路:就是利用遍历,将不等于‘0’的添加到新的数组中,返回新数组的长度和新数组,最后打印出来即可。

def CompactIntegers():
    n = int(input())
    n_list = input().split()
    new_list = []
    for i in n_list:
        if i != '0':
            new_list.append(i)
    n1 = len(new_list)
    return n1,new_list
n,s = CompactIntegers()
print(n)
for i in s:
    print(int(i),end=' ')
发布了81 篇原创文章 · 获赞 10 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/Python_Matlab/article/details/104696042