PAT A1035 Password (20)[密码,字符串]

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2

1
team110 abcdefg332

Sample Output 2

There is 1 account and no account is modified

Sample Input 3

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3

There are 2 accounts and no account is modified

思路1

  1. 对于输入的每个姓名和密码,逐位检查密码中的每一位,满足条件则修改并标记,将结果保存下来
  2. 根据结果集的数量分情况输出

代码1

#include <iostream>
#include <vector>
#include <string>
using namespace std;

int main()
{
    int n;
    string name, password;
    cin >> n;
    vector<string> res;
    for (int i = 0; i < n; i++)
    {
        cin >> name >> password;
        int len = password.size();
        bool flag = false; // 是否被修改
        for (int j = 0; j < len; j++)
        {
            switch (password[j])
            {
            case '1':
                password[j] = '@';
                flag = true;
                break;
            case '0':
                password[j] = '%';
                flag = true;
                break;
            case 'l':
                password[j] = 'L';
                flag = true;
                break;
            case 'O':
                password[j] = 'o';
                flag = true;
                break;
            }
        }
        if (flag) // 被修改过
        {
            string row = name + " " + password;
            res.push_back(row);
        }
    }
    int cnt = res.size();
    if (cnt == 0)
    {
        if (n == 1)
            cout << "There is 1 account and no account is modified" << endl;
        else
            cout << "There are " << n << " accounts and no account is modified" << endl;
    }
    else
    {
        cout << cnt << endl;
        for (int i = 0; i < cnt; i++)
            cout << res[i] << endl;
    }
    return 0;
}
发布了166 篇原创文章 · 获赞 27 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/HdUIprince/article/details/105463778