1001 A+B Format (Python实现)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

Python实现:

a, b = map(int, input().split())
c = a+b
d = abs(c)
sign = '' if c >= 0 else '-'
if d < 1000:
    print(c)
else:
    e = str(d)
    print(sign, end="")
    for i in range(len(e)):
        print(e[i], end="")
        if (len(e)-i) % 3 == 1 and i != len(e)-1:
            print(',', end="")
# 手工检测并用逗号分隔,其实可以直接用format(a+b,',')
发布了79 篇原创文章 · 获赞 100 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/lee1hong/article/details/103336194