1053 Path of Equal Weight (30 分)

                                                                  1053 Path of Equal Weight (30 分)

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

accept  code:

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int N,M,S;
int w[110];
int path[110];//用来记录路径的结点 
struct Node{
	int weight;
	vector<int> child;
}node[110];

bool cmp(int a,int b)
{
	return 	node[a].weight>node[b].weight;
}

//index是当前访问结点,numnode是当前路径path上的结点的个数,sum是当前的结点的权值之和 
void presort(int index, int numnode,int sum)//先根遍历所有的结点 
{
	if(sum>S) return;//超过了给定的权重和
	if(sum==S)//刚好相等做相应处理 
	{
		if(node[index].child.size()!=0) return;//证明不是叶子结点 
		for(int q=0;q<numnode;q++)//否则输出当前路径的结点的权重 
		{
			printf("%d",node[path[q]].weight);
			if(q<numnode-1) printf(" ");
			else printf("\n"); 
		} 
		return;
	}
	
	//遍历当前结点的所有子节点
	for(int r=0;r<node[index].child.size();r++)
	{
		int child=node[index].child[r];//子节点标号
		path[numnode]=child;
		presort(child,numnode+1,sum+node[child].weight);
	} 
}

int main()
{
	cin>>N>>M>>S;
	for(int i=0;i<N;i++)
		cin>>node[i].weight;//存放每个节点的权重,下标从0开始且每个两位数的节点(下标)对应的值就是相应权重 
		
//接下来有M行,每一行一个结点以及其权重信息和其子节点的标号
	int t;//该结点的子节点个数
	int nod;//该结点的下标 
	int nextnod;
	for(int j=0;j<M;j++)
	{
//		cin>>nod>>t;
		scanf("%d%d",&nod,&t);
		for(int k=0;k<t;k++)
		{
//			cin>>nextnod;
			scanf("%d",&nextnod);
//			node[t].data=w[nod];
			node[nod].child.push_back(nextnod);
		} 
//将每个节点所连接的子节点的权重进行排序,从大到小 
		sort(node[nod].child.begin(),node[nod].child.end(),cmp);
	}
	path[0]=0;
	presort(0,1,node[0].weight);
	return 0;
} 
原创文章 54 获赞 99 访问量 1万+

猜你喜欢

转载自blog.csdn.net/qq_38938670/article/details/89196262