二叉搜索树的结构

二叉搜索树或者是一棵空树,或者是具有下列性质的二叉树: 若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值;若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值;它的左、右子树也分别为二叉搜索树。(摘自百度百科)
给定一系列互不相等的整数,将它们顺次插入一棵初始为空的二叉搜索树,然后对结果树的结构进行描述。你需要能判断给定的描述是否正确。例如将{ 2 4 1 3 0 }插入后,得到一棵二叉搜索树,则陈述句如“2是树的根”、“1和4是兄弟结点”、“3和0在同一层上”(指自顶向下的深度相同)、“2是4的双亲结点”、“3是4的左孩子”都是正确的;而“4是2的左孩子”、“1和3是兄弟结点”都是不正确的。
输入格式:
输入在第一行给出一个正整数N(≤100),随后一行给出N个互不相同的整数,数字间以空格分隔,要求将之顺次插入一棵初始为空的二叉搜索树。之后给出一个正整数M(≤100),随后M行,每行给出一句待判断的陈述句。陈述句有以下6种:
A is the root,即"A是树的根";
A and B are siblings,即"A和B是兄弟结点";
A is the parent of B,即"A是B的双亲结点";
A is the left child of B,即"A是B的左孩子";
A is the right child of B,即"A是B的右孩子";
A and B are on the same level,即"A和B在同一层上"。
题目保证所有给定的整数都在整型范围内。
输出格式:
对每句陈述,如果正确则输出Yes,否则输出No,每句占一行。
输入样例:
5
2 4 1 3 0
8
2 is the root
1 and 4 are siblings
3 and 0 are on the same level
2 is the parent of 4
3 is the left child of 4
1 is the right child of 2
4 and 0 are on the same level
100 is the right child of 3
输出样例:
Yes
Yes
Yes
Yes
Yes
No
No
No

#include <iostream>
#include <algorithm>
#include <string>
#include <deque>
#include <cstring>
#include <queue>
#include <vector>
#include <cstdio>
#include <unordered_map>
#include <cmath>
using namespace std;
struct node
{
 int val, no;
 node *left;
 node *right;
 node(int x, int n)
 {
  val = x;
  no = n;
  left = right = nullptr;
 }
};
unordered_map<int, int> mp; 
unordered_map<int, bool> st; 
void insert(node*& root, int val, int n)
{ 
 if(!root)
 {
  mp[val] = n;
  root = new node(val, n);
 }
 else if(root->val < val)
 {
  insert(root->right, val, 2*n+1);
 }
 else 
 {
  insert(root->left, val, 2*n);
 }
}
int main()
{
 int n, x, y;
 cin>>n;
 node* root = nullptr;
 for(int i = 0; i < n; i++)
 {
  cin>>x;
  st[x] = true; 
  insert(root, x, 1);
 }
 int k;
 cin>>k;
 string str;
 while(k--)
 {
  cin>>x;
  cin>>str;
  bool res = false;
  if(str[0] == 'a')
  { 
   cin>>y>>str>>str;
   if(str[0] == 's')
   { //A和B是兄弟 
    if(st[x] && st[y] && mp[x]/2 == mp[y]/2) res = true;
   }
   else
   { //A和B在同一层 
    cin>>str>>str>>str; 
    int u = log(mp[x])/log(2);
    int v = log(mp[y])/log(2);
    if(st[x] && st[y] && u == v) 
    {
     res = true; //通过取对数 直接计算层数 
    }
   } 
  }
  else
  {
   cin>>str>>str;
   if(str == "root")
   {
    if(st[x] && mp[x] == 1) 
    {
     res = true;  //A是根 
    }
   }
   else if(str == "left")
   {  //A是B的左孩子 
    cin>>str>>str>>y;
    if(st[x] && st[y] && 2*mp[y] == mp[x]) 
    {
     res = true;
    }
   }
   else if(str == "right")
   { //A是B的右孩子 
    cin>>str>>str>>y;
    if(st[x] && st[y] && 2*mp[y]+1 == mp[x]) 
    {
     res = true;  
    }
   }
   else if(str == "parent")
   {
    cin>>str>>y;
    if(st[x] && st[y] && mp[y]/2 == mp[x]) 
    {
     res = true; //A是B的双亲 
    }
   }
  }
  if(res) 
  {
   cout<<"Yes"<<endl;
  }
  else 
  {
   cout<<"No"<<endl;
  }
 }
 return 0;
} 
原创文章 326 获赞 309 访问量 3万+

猜你喜欢

转载自blog.csdn.net/huangziguang/article/details/105922448