GRE function

ID

5-6-4

Description

Verify IPv6 over IPv4 using GRE tunnel

Topology

 

Step

  1. Network between sw1 and port A configures as ipv6 network,network between sw1 and sw2 configures as ipv4 network, network between sw2 and port B configures as ipv6 network;
  2. Configure GRE tunnel between sw1 and sw2;
  3. Generate ipv6 traffic from port A to B,B to A;

Script

sw1

enable

vlan database

vlan 10,100

vlan routing 10

vlan routing 100

exit

configure

ip routing

ipv6 unicast-routing

ipv6 route 2000::/64 interface tunnel 1 fe80::a01:101

interface 0/8

vlan participation include 100

vlan pvid 100

exit

interface 0/32               

vlan participation include 10

vlan pvid 10

exit

interface vlan 100

ipv6 address 1000::1/64

interface vlan 10

ip address 10.1.1.1 255.255.255.0

exit

interface tunnel 1

ipv6 enable

ipv6 address 3000::1/64

tunnel mode ipv6ip

tunnel source 10.1.1.1

tunnel destination 10.1.1.2

exit

sw2:

enable

vlan database

vlan 10,100

vlan routing 10

vlan routing 100

exit

configure

ip routing

ipv6 unicast-routing

ipv6 route 1000::/64 interface tunnel 1 fe80::a01:102

interface 0/8

vlan participation include 100

vlan pvid 100

exit

interface 0/32               

vlan participation include 10

vlan pvid 10

exit

interface vlan 100

ipv6 address 2000::1/64

interface vlan 10

ip address 10.1.1.2 255.255.255.0

exit

interface tunnel 1

ipv6 enable

ipv6 address 3000::2/64

tunnel mode ipv6ip

tunnel source 10.1.1.2

tunnel destination 10.1.1.1

exit

Expectation

  1. In step 3, GRE tunnel can establish successfully.
  2. In step 3, ipv6 traffic from port A to B, B to A can be transmitted successfully;

Result

pass

猜你喜欢

转载自www.cnblogs.com/maisha/p/12911845.html
gre