ayit第十四周训练k题

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5

Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample:

          7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *

  4   5   2   6   5

The highest score is achievable by traversing the cows as shown above.

Sponsor

​
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
int a[500][500];
int main()
{
	int n,i,j,k;
	while(~scanf("%d",&n))
	{
		for(i=1;i<=n;i++)
			for(j=1;j<=i;j++)
				scanf("%d",&a[i][j]);
		for(i=n;i>=1;i--)
			for(j=1;j<=i-1;j++)
				a[i-1][j]=max(a[i][j],a[i][j+1])+a[i-1][j];
			printf("%d\n",a[1][1]);
	}
	return 0;
}

​

题意      给定一个数塔,第i行有i个数。需要找到一条从树顶结点遍历到树底结点的最长路径,遍历的结点中数字相加的和                          最大。每个结点只能向其下层相邻的左右两个结点遍历。

思路   从倒数第二层开始遍历,每一次选择dp[i+1][j]与dp[i+1][j+1]中的较大值加到dp[i][j]上,最后第一层的数就是最大值。

猜你喜欢

转载自blog.csdn.net/m0_46628834/article/details/106242248