POJ 1724:ROADS

总时间限制: 1000ms 内存限制: 65536kB
描述
N cities named with numbers 1 … N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.

输入
The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :
S is the source city, 1 <= S <= N
D is the destination city, 1 <= D <= N
L is the road length, 1 <= L <= 100
T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.

输出
The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.
If such path does not exist, only number -1 should be written to the output.

样例输入
5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

样例输出
11

来源
CEOI 1998

代码:

#include <iostream>
#include <vector>
#include <cstring>
using namespace std;
int k,n,r;//总钱  城市数   路的数量 
struct road
{
	int d,l,t;//每条路的终点,距离和花费 
};
vector< vector<road> > G(110); //邻接表
int minL[110][10010];//minL[k][m]表示经过第k个城市、总花费为m时的最小长度 
int minLen;
int totalLen;
int totalCost;
int visited[110];//标记数组 

void dfs(int s)
{
	if(s==n) //到了终点时取最小的 
	{
		minLen=min(minLen,totalLen);
		return ;
	}
	for(int i=0;i<G[s].size();i++)
	{
		road R=G[s][i];
		
		if(totalCost+R.t>k) continue;//可行性剪枝 
		if(totalLen+R.l>minLen) continue;//最优性剪枝 
		if(totalLen+R.l>=minL[R.d][totalCost+R.t]) continue;
		minL[R.d][totalCost+R.t]=totalLen+R.l; 
		
		if(!visited[R.d])
		{	
			totalLen+=R.l;
			totalCost+=R.t;
			visited[R.d]=1;
			dfs(R.d);
			
			visited[R.d]=0;
			totalLen-=R.l;
			totalCost-=R.t;
		}
	}
}

int main()
{
	cin>>k>>n>>r;
	for(int i=0;i<r;i++)
	{
		int s;
		road R;
		cin>>s>>R.d>>R.l>>R.t;
		if(s!=R.d) G[s].push_back(R); 
	}
	memset(visited,0,sizeof(visited));
	for(int i=0;i<110;i++)
	for(int j=0;j<10010;j++)
	minL[i][j]=0x3f3f3f3f;
	totalLen=0;
	minLen=0x3f3f3f3f;
	totalCost=0;
	visited[1]=1;
	dfs(1);
	if(minLen<0x3f3f3f3f)
	{
		cout<<minLen<<endl;
	}
	else cout<<"-1"<<endl;
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/BitcoinR/article/details/108422907