PAT甲级真题1008 Elevator 【简单叠加计算】

1008 Elevator (20分)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.
Output Specification:

For each test case, print the total time on a single line.
Sample Input:

3 2 3 1

Sample Output:

41

代码实现

这次我将试着使用C++来完成。

#include <iostream>
using namespace std;

int main()
{
    
    
	int a;
	cin >> a;//用户输入第一个数据
	int now=0;//当前所在的楼层 
	int sum=0;//计算总共花费的时间 
	while(cin>>a)//这个判断句实际上指的是这个操作已经被完成了,所以它的结果为true,而不是再执行一次。
	{
    
    
		if(a>now)//需要上楼
		{
    
    
			sum = sum + (a-now)*6;
		 } 
		else if(a<now)//需要下楼 
		{
    
    
			sum = sum + (now - a)*4;
		}
		
		sum = sum+5;//每层停留五秒 
		now = a;//改变当前楼层 
	 } 
	printf("%d",sum);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Cambridge26/article/details/108947170