【编程题解】88888888...

Description

Eight is a lucky number in our daily life. If every digit of a number consists of eight,it is considered a lucky number.

The teacher now gave Lili a positive integer L, hoping that she could find out how many positive integers made up of 8 together are multiples of L, and asked for the minimum value. Lili felt very difficult, could you do it for her?

Input

The input contains multiple sets of test cases.

Each set of test cases occupies one row and contains an integer L.

When the input case L=0, the input is terminated and the use case does not need to be processed.

Data range:1≤L≤2∗10^9

Output

Each set of test cases has one line of output.

The result is "Case 1:" + an integer N, which represents the number of bits of the least lucky number that satisfies the condition.

If the lucky number that satisfies the condition does not exist, then N=0.

扫描二维码关注公众号,回复: 11943436 查看本文章

Sample Input 1 

8
11
16
0

Sample Output 1

Case 1:1
Case 2:2
Case 3:0

Personal Answer  (using language:JAVA)  Not necessarily right

import java.math.BigInteger;
import java.util.List;
import java.util.LinkedList;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        int times = 0;
        List<Integer> results = new LinkedList<>();
        int input = scanner.nextInt();
        while (input!=0){
            times++;
            results.add(cal(input));
            input = scanner.nextInt();
        }
        for (int i=0;i<results.size();i++){
            System.out.println("Case "+(i+1)+":"+results.get(i));
        }
    }

    public static int cal(int input){
        int weishu=(input+"").length();
        int tip=0;
        do{
            tip++;
            String s="";
            for(int i=0;i<tip;i++){
                s+="8";
            }
            BigInteger test_num=new BigInteger(s);
            BigInteger res =test_num.mod(new BigInteger(""+input));
            if(res.equals(new BigInteger("0"))){
                return tip;
            }
        }while(tip!=9999);
        return 0;
    }
}

Welcome to communicate!

猜你喜欢

转载自blog.csdn.net/Ximerr/article/details/106751452