30行代码AC_HDU-5933 ArcSoft‘s Office Rearrangement(模拟+题解报告)

励志用更少的代码做更高效的表达


ArcSoft, Inc. is a leading global professional computer photography and computer vision technology company.

There are N working blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into K new blocks by the following two operations:

merge two neighbor blocks into a new block, and the new block’s size is the sum of two old blocks’.
split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block.

Now the CEO wants to know the minimum operations to re-arrange current blocks into K block with equal size, please help him.

Input
First line contains an integer T, which indicates the number of test cases.

Every test case begins with one line which two integers N and K, which is the number of old blocks and new blocks.

The second line contains N numbers a1, a2, ⋯, aN, indicating the size of current blocks.

Limits
1≤T≤100
1≤N≤10^5
1≤K≤10^5
1≤ai≤10^5

Output
For every test case, you should output ‘Case #x: y’, where x indicates the case number and counts from 1 and y is the minimum operations.

If the CEO can’t re-arrange K new blocks with equal size, y equals -1.

Sample Input
3
1 3
14
3 1
2 3 4
3 6
1 2 3

Sample Output
Case #1: -1
Case #2: 2
Case #3: 3


模拟题, 别想的太复杂。 分解+组合为一组、两次操作。


代码展示

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

int a[100010];
int main() {
    
    
	int T; scanf("%d", &T);
	for(int t = 1; t <= T; t++) {
    
    
		ll n, k, sum=0, sum1=0, x=0;
		scanf("%lld%lld", &n, &k);
		for(int i = 0; i < n; i++) {
    
    
			scanf("%d", &a[i]);
			sum+=a[i];
		}
		if(sum%k) {
    
    
			printf("Case #%d: -1\n",t);
		} else {
    
    
			k = sum/k;
			for(int i = 0; i < n; i++) {
    
    
				x += a[i];
				while(x > k) {
    
    
					x -= k;
					sum1++;
				}
				if(x == k) x = 0;
				else sum1++;
			}
			printf("Case #%d: %lld\n", t,sum1);
		}
	}
return 0; }

日拱一卒,功不唐捐。

猜你喜欢

转载自blog.csdn.net/weixin_43899069/article/details/109146288