C/C++编程学习 - 第3周 ⑤ 计算两点间距离

题目链接

题目描述

输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。

Input
输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。

Output
对于每组输入数据,输出一行,结果保留两位小数。

Sample Input

0 0 0 1
0 1 1 0

Sample Output

1.00
1.41

思路

输入两点坐标,计算并输出两点间的距离。

注意三点:
①用平方根计算两点间的距离,平方根函数是sqrt()
②使用平方根函数,需要带头文件#include<math.h>
③注意多组输入

C语言代码:

#include<stdio.h>
#include<math.h>
int main()
{
    
    
	double x1,y1,x2,y2;
	while(~scanf("%lf %lf %lf %lf", &x1, &y1, &x2, &y2))
		printf("%.2lf\n",sqrt((x1 - x2) * (x1 - x2) + (y1 - y2) * (y1 - y2)));
	return 0;
}

C++代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    
    
	double x1, y1, x2, y2;
	while(cin >> x1 >> y1 >> x2 >> y2)
		printf("%.2lf\n", sqrt((x1 - x2) * (x1 - x2) + (y1 - y2) * (y1 - y2)));
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_44826711/article/details/112860737