1031 Hello World for U (20 point(s))

思路:

利用公式求得  n1, n2, n3,然后输出 U

1031 Hello World for U (20 point(s))

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

Example:

#include<iostream>
#include<vector>
using namespace std;

int main()
{
    string hello;
    cin >> hello;
    int size = hello.size();
    int k = 0, n2;
    for(n2 = 3; n2 <= size - 2; n2++) {
        k = (size - n2 + 1) / 2 + 1;
        if(k <= n2 && (2*k-2+n2==size)) break;
    }
    for(int i = 1; i < k; i++) {
        cout << hello[i-1];
        for(int j = 0; j < n2 - 2; j++) cout << ' ';
        cout << hello[size-i] << endl;
    }
    cout << hello.substr(k-1, n2) << endl;
}

猜你喜欢

转载自blog.csdn.net/u012571715/article/details/114116613