HDU -4022 Bombing

传送门

问题描述:

It’s a cruel war which killed millions of people and ruined series of cities. In order to stop it, let’s bomb the opponent’s base.
It seems not to be a hard work in circumstances of street battles, however, you’ll be encountered a much more difficult instance: recounting exploits of the military. In the bombing action, the commander will dispatch a group of bombers with weapons having the huge destructive power to destroy all the targets in a line. Thanks to the outstanding work of our spy, the positions of all opponents’ bases had been detected and marked on the map, consequently, the bombing plan will be sent to you.
Specifically, the map is expressed as a 2D-plane with some positions of enemy’s bases marked on. The bombers are dispatched orderly and each of them will bomb a vertical or horizontal line on the map. Then your commanded wants you to report that how many bases will be destroyed by each bomber. Notice that a ruined base will not be taken into account when calculating the exploits of later bombers.

输入说明:

Multiple test cases and each test cases starts with two non-negative integer N (N<=100,000) and M (M<=100,000) denoting the number of target bases and the number of scheduled bombers respectively. In the following N line, there is a pair of integers x and y separated by single space indicating the coordinate of position of each opponent’s base. The following M lines describe the bombers, each of them contains two integers c and d where c is 0 or 1 and d is an integer with absolute value no more than 109, if c = 0, then this bomber will bomb the line x = d, otherwise y = d. The input will end when N = M = 0 and the number of test cases is no more than 50.

输出说明:

For each test case, output M lines, the ith line contains a single integer denoting the number of bases that were destroyed by the corresponding bomber in the input. Output a blank line after each test case.

SAMPLE INPUT:

3 2
1 2
1 3
2 3
0 1
1 3
0 0

SAMPLEOUTPUT:

2
1

思路:

题意是输入一系列基地的点,然后给出两架飞机进行轰炸的起始点,问每一架飞机能摧毁几个基地,注意被前一架飞机摧毁的基地不会再次重复计算。飞机能够摧毁一条竖线或者是横线(由输入时的c的值来决定)。

AC代码:

#include<bits/stdc++.h>
using namespace std;
map<int,multiset<int>>ax,ay;
multiset<int>::iterator iter;
int main()
{
    
    
   int m,n,x,y,c,d,i;
   while(scanf("%d%d",&n,&m)&&n&&m)//首先输入所有基地的相对位置
   {
    
    
       for(int i=0;i<n;i++)
       {
    
    
           scanf("%d%d",&x,&y);
           ax[x].insert(y);
           ay[y].insert(x);
       }
       for(i=1;i<=m;i++)
       {
    
    
           scanf("%d%d",&c,&d);
           if(c)
           {
    
    
               printf("%d\n",ay[d].size());//输出在d这一行所包含的目标个数
               for(multiset<int>::iterator i=ay[d].begin();i!=ay[d].end();i++)//删除已经摧毁的目标个数
               {
    
    
                   ax[*i].erase(d);
               }
               ay[d].clear();
           }
           else
           {
    
    
               printf("%d\n",ax[d].size());//输出d这一列所包含的目标个数
               for(multiset<int>::iterator i=ax[d].begin();i!=ax[d].end();i++)//删除已经摧毁的目标个数
               {
    
    
                   ay[*i].erase(d);
               }
               ax[d].clear();
           }
       }
       cout<<endl;
   }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_51727949/article/details/114641886
hdu