AYIT-2020 609第十六周周赛 D - 搜索(Knight Moves)

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the
shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard
exactly once. He thinks that the most difficult part of the problem is determining the smallest number
of knight moves between two given squares and that, once you have accomplished this, finding the tour
would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the
”difficult” part.
Your job is to write a program that takes two squares a and b as input and then determines the
number of knight moves on a shortest route from a to b.
Input
The input file will contain one or more test cases. Each test case consists of one line containing two
squares separated by one space. A square is a string consisting of a letter (a…h) representing the column
and a digit (1…8) representing the row on the chessboard.
Output
For each test case, print one line saying ‘To get from xx to yy takes n knight moves.’.
Sample Input
e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6
Sample Output
To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

这是bfs 的水题, 这是学习马跳的问题,马可以跳八个方向,而且根据原理,马是可以调到棋盘的任一方向的,用bfs 的队列找到的第一条路径就是了

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <iostream>
#include <queue> 
using namespace std;
#define max 12
int G[max][max];//棋盘
int dir[8][2]= {
    
    {
    
    1,-2},{
    
    2,-1},{
    
    2,1},{
    
    1,2},{
    
    -1,2},{
    
    -2,1},{
    
    -2,-1},{
    
    -1,-2}};//8个方向
int step;//步数
int sx,sy,fx,fy;
struct node
{
    
    
    int x,y,step;
};
void xia()
{
    
    
    memset(G,0,sizeof(G));//清空地图
    queue<node> q;
    node p,next;
    p.x=sx;//起点
    p.y=sy;
    p.step=0;
    G[p.x][p.y]=1;//标记
    q.push(p);//放入
    while(!q.empty())
    {
    
    
        p=q.front();//第一个
        q.pop();//删除第一个
        if(p.x==fx&&p.y==fy)//到终点
        {
    
    
            step=p.step;
            return ;
        }
        for(int i=0; i<8; i++)//8个方向搜索
        {
    
    
            next.x=p.x+dir[i][0];
            next.y=p.y+dir[i][1];
            if(next.x>=1&&next.y>=1&&next.x<=8&&next.y<=8&&G[next.x][next.y]==0)//在棋盘中且没有被标记
            {
    
    
                next.step=p.step+1;
                G[next.x][next.y]=1;
                q.push(next);
            }
        }
    }
}
int main()
{
    
    
    char c1,c2;
    int y1,y2;
    while(~scanf("%c%d %c%d",&c1,&y1,&c2,&y2))
    {
    
    
        getchar();//吸收回车键
        sx=c1-'a'+1;//起点
        sy=y1;
        fx=c2-'a'+1;//终点
        fy=y2;
        xia();//广搜
     	printf("To get from %c%d to %c%d takes %d knight moves.\n",c1,y1,c2,y2,step);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/csx_zzh/article/details/106607859