C++实验---时间之差

时间之差

Description
定义一个类Time,包含小时、分钟、秒三个属性。定义其构造函数Time(int, int, int)分别初始化其小时、分钟、秒。重载减法运算符,用于求两个时间之间相差的秒数(非负整数)。
Input
输入有2行。每行表示1个时间,包括小时、分钟、秒三个值。输入都是合法的24小时制的时间。
Output
见样例。
Sample Input

12 10 10
10 20 20

Sample Output

Deference is 6590 seconds.

题目给定代码

int main()
{
    
    
    int a, b, c;
    cin>>a>>b>>c;
    Time t1(a, b, c);
    cin>>a>>b>>c;
    Time t2(a, b, c);
    cout<<"Deference is "<<(t2 - t1)<<" seconds."<<endl;
    return 0;
}

code:

#include<iostream>
#include<math.h>

using namespace std;


class Time{
    
    
	int hh;//小时
	int mm;//分钟
	int ss;//秒
public:
	Time(int h,int m,int s){
    
    //构造函数
		hh=h;
		mm=m;
		ss=s;
	}
	
	friend int operator -(const Time &t1,const Time &t2){
    
    
		int time1=t1.hh*3600+t1.mm*60+t1.ss;
		int time2=t2.hh*3600+t2.mm*60+t2.ss;
		return abs(time1-time2);//注意返回非负整数
	}
	
};


int main()
{
    
    
    int a, b, c;
    cin>>a>>b>>c;
    Time t1(a, b, c);
    cin>>a>>b>>c;
    Time t2(a, b, c);
    cout<<"Deference is "<<(t2 - t1)<<" seconds."<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/timelessx_x/article/details/115217063