POJ - 1753 Flip Game(枚举)

                                                Flip Game

Time Limit: 1000MS   Memory Limit: 65536K

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 

  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

题意: 翻卡片,翻一动五(如果有),问最少多少次变成全白或者全黑

解题思路:可以dfs枚举所有可能但没啥意思。   对一张卡片进行两次翻转是没有意义的,我们从第一行开始,一次确定每一行全0或者全1,即翻转完第i+1行后要保证第i行全0或者全1,因此一旦第i行翻转完成,第i+1行要进行的翻转操作也就确定了。我们只需枚举第一行的翻转操作,然后确定最后一行是否为全0或者全1就可以了。 时间复杂度由dfs枚举的2^(n^2)降为2^n.

ACCode:

#include <iostream>
#include <cstdio>
using namespace std;
int mp[6][6],t[6][6];
bool Judge()
{
	for(int j=1;j<=4;j++)
		if(t[4][j] != t[4][1])
			return false;
	return true;
}
void flip(int x,int y)
{
	t[x][y] = 1^t[x][y];
	t[x+1][y] = 1^t[x+1][y]; // 越界处不判断,无影响 
	t[x-1][y] = 1^t[x-1][y];
	t[x][y+1] = 1^t[x][y+1];
	t[x][y-1] = 1^t[x][y-1];
}
void _copy()
{
	for(int i=1;i<=4;i++)
		for(int j=1;j<=4;j++)
			t[i][j] = mp[i][j];
}
int main()
{
	char tin;
	for(int i=1;i<=4;i++) {
		for(int j=1;j<=4;j++) {
			cin >> tin;
			mp[i][j] = tin=='b'? 1:0;
		}
	}
	int tot=0,ans=0x3f3f3f3f;
	// 全 0
	for(int i=0;i<=15;i++) {	//枚举对第一行的操作
		_copy();
		tot=0;
		for(int k=0;k<4;k++) {
			if((1 << k) & i) {
				flip(1,k+1);
				tot++;
			}
		}
		for(int r=2;r<=4;r++) {  //对后3行操作
			for(int c=1;c<=4;c++) {
				if(t[r-1][c]) {
					flip(r,c);
					tot++;
				}
			}
		}
		if(Judge()) 
			ans = min(ans,tot);
	}
	// 全 1
	for(int i=0;i<=15;i++) {	//枚举对第一行的操作
		_copy();
		tot=0;
		for(int k=0;k<4;k++) {
			if((1 << k) & i) {
				flip(1,k+1);
				tot++;
			}
		}
		for(int r=2;r<=4;r++) {  //对后3行操作
			for(int c=1;c<=4;c++) {
				if(!t[r-1][c]) {
					flip(r,c);
					tot++;
				}
			}
		}
		if(Judge()) 
			ans = min(ans,tot);
	}
	if(ans == 0x3f3f3f3f) 
		printf("Impossible\n");
	else  
		printf("%d\n",ans);
}

猜你喜欢

转载自blog.csdn.net/weixin_42765557/article/details/97558447