POJ - 3279 Fliptile 【枚举】

                                                  Fliptile

Time Limit: 2000MS   Memory Limit: 65536K

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

解题思路

枚举第一行状态,递归处理后面n-1行的状态,和这一题POJ - 1222 EXTENDED LIGHTS OUT基本一样的,就是需要在存第一行状态的时候从高位到低位存,以保证字典序从小到大。 分解数字1为6位二进制:(000001) < ( 100000) :

ACCode

#include <iostream>
#include <cmath>
#include <cstring> 
#include <cstdio>
using namespace std;
int mp[20][20],t[20][20],n,m;
int _set[20],f[20][20],ans[20][20],best;
bool Judge()
{	
	for(int j=1;j<=m;j++)
		if(t[n][j] != 0)
			return false;
	return true;
}
void flip(int x,int y)
{
	t[x][y] ^= 1;
	if(x > 1) t[x-1][y] ^= 1;
	if(x < n) t[x+1][y] ^= 1;
	if(y > 1) t[x][y-1] ^= 1;
	if(y < m) t[x][y+1] ^= 1;
}
void change(int r,int tot)
{
	if(r == n+1) {
		if(Judge() && tot < best) {
			best = tot;
			for(int i=1;i<=n;i++) 
				for(int j=1;j<=m;j++)
					ans[i][j] = f[i][j];
		}
		return ;
	}
	
	if(tot >= best)	return ;
	
	int add = 0;
	for(int j=1;j<=m;j++)
		if(_set[j]) {
			flip(r,j);
			add++;
		}
	
	for(int j=1;j<=m;j++) {
		f[r][j] = _set[j];
		_set[j] = t[r][j];
	}	
	change(r+1,tot+add);
}
int main()
{
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++) 
		for(int j=1;j<=m;j++)
			scanf("%d",&mp[i][j]);
			
	best = 0x3f3f3f3f;
	int k = pow(2,m);
	for(int c=0;c<k;c++) {
		for(int i=1;i<=n;i++)
			for(int j=1;j<=m;j++) 
				t[i][j] = mp[i][j];
				
		for(int j=1;j<=m;j++) _set[j] = 0;
		int t = c;
		int j = m;  // 保证先测试字典序小的方案 
		while(t != 0) {
			_set[j] = t%2;
			t /= 2;
			j--;	
		}
		change(1,0);
	}
	
	if(best == 0x3f3f3f3f)
		printf("IMPOSSIBLE\n");
	else {
		for(int i=1;i<=n;i++) {
			for(int j=1;j<=m;j++) {
				printf("%d",ans[i][j]);
				if(j != m)
					printf(" ");
			}
			printf("\n");
		}
	}
	return 0; 
}

 

猜你喜欢

转载自blog.csdn.net/weixin_42765557/article/details/90273030