POJ - 1836 Alignment 【动态规划】

                                            Alignment

Time Limit: 1000MS   Memory Limit: 30000K

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

题意

n个士兵排成一行,让最少的士兵出列,使得每个士兵都能看到至少一个最边上的士兵(中间某个人能看到最边上的士兵的条件是该士兵的身高一定强大于他某一边所有人的身高),身高序列可以是这样:1  2  3   4   5   4   3   2   1  或者   1   2   3   4   5   5   4   3   2   1。(来自博主smile_kai)

解题思路

不就是求从左到右和从右到左的(不交)最长上升子序列ma。

先分别求从左到右和右到左的最长上升子序列(分别用数组dpl和dpr记录),这里的dpl/r [ j ]必须包含 j。

然后求两个上升子序列和的最大值,即dpl [ i ] + dpr [ j ],注意j要> i,  得到的就是最多可以同时存在士兵数,总数减去他,就是需要出列的最少士兵数了

AC Code

#include <iostream>
#include <cstdio>
#include <algorithm> 
using namespace std;

int main()
{
	double a[1005];
	int n;
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
		scanf("%lf",&a[i]);
		
	int dpl[1005],dpr[1005];
	for(int i=0;i<=n+1;i++) {
		dpl[i] = 1;
		dpr[i] = 1;
	}

	for(int i=1;i<=n;i++) {
		for(int j=1;j<i;j++) {
			if(a[j] < a[i])
				dpl[i] = max(dpl[i],dpl[j]+1);
		}
	}
	for(int i=n;i>=1;i--) {
		for(int j=n;j>i;j--) {
			if(a[j] < a[i])
				dpr[i] = max(dpr[i],dpr[j]+1);
		}
	}

	int ans=-1;
	for(int i=1;i<=n;i++) {
		for(int j=i+1;j<=n;j++)
			ans = max(ans,dpl[i]+dpr[j]);	
	}
	printf("%d\n",n-ans);
}

猜你喜欢

转载自blog.csdn.net/weixin_42765557/article/details/89682430