HDU 1159 Common Subsequence (动态规划--最大公共子序列)

题目

链接

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, …, xm> another sequence Z = <z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab
programming contest
abcd mnp

Sample Output

4
2
0

一、分析

好家伙题目看了半天,结果这道题只要看到最后一句就可以了。。。。
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
就是要你求最大公共子序列
关于最大公共子序列:https://blog.csdn.net/wenrenfudi/article/details/112687241

二、代码

代码如下(示例):

#include<stdio.h>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#define inf 99999999
//给定两个序列X和Y,问题是求X和Y的最大公共子序列的长度。
long long dp[10005][10005];
char a[100005],b[100005];
int main()
{
    
    
    int len1,len2;
    while(scanf("%s%s",&a,&b)==2)
    {
    
    
        len1=strlen(a);
        len2=strlen(b);
        for(int i=0;i<=len1;i++)
        {
    
    
            for(int j=0;j<=len2;j++)
            {
    
    
                dp[0][i]=0;//行和列都赋值为0
                dp[j][0]=0;
            }
        }
        for(int i=1;i<len1+1;i++)
        {
    
    
            for(int j=1;j<len2+1;j++)
            {
    
    
                if(a[i-1]==b[j-1])
                    dp[i][j]=dp[i-1][j-1]+1;
                else if(a[i-1]!=b[j-1])
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
            }
        }
        printf("%d\n",dp[len1][len2]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wenrenfudi/article/details/115015423