Duizi and Shunzi(贪心)

Nike likes playing cards and makes a problem of it.

Now give you n integers, ai(1in)

We define two identical numbers (eg: 2,2) a Duizi,
and three consecutive positive integers (eg: 2,3,4) a Shunzi.

Now you want to use these integers to form Shunzi and Duizi as many as possible.

Let s be the total number of the Shunzi and the Duizi you formed.

Try to calculate max(s)
.

Each number can be used only once.
Input The input contains several test cases.

For each test case, the first line contains one integer n( 1n106).
Then the next line contains n space-separated integers ai ( 1ain)
Output For each test case, output the answer in a line.
Sample Input
7
1 2 3 4 5 6 7
9
1 1 1 2 2 2 3 3 3
6
2 2 3 3 3 3 
6
1 2 3 3 4 5
Sample Output
2
4
3
2


        
  
Hint
Case 1(1,2,3)(4,5,6)

Case 2(1,2,3)(1,1)(2,2)(3,3)

Case 3(2,2)(3,3)(3,3)

Case 4(1,2,3)(3,4,5)



        
 


这道题看起来好像只能用dp,其实正解贪心就可以了。(还是太年轻)

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>

typedef long long LL;
using namespace std;
int a[1000010];
int book[1000010];
int main()
{
    int n,ans;
    while(scanf("%d",&n)!=EOF){
            ans=0;
            memset(book,0,sizeof(book));
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            book[a[i]]++;
        }
        for(int i=1;i<=n;i++){
            if(book[i-1]==1&&book[i-2]==1&&book[i]>0){
                ans++;
                book[i]--;
                book[i-2]--;
                book[i-1]--;
            }//先处理前面只剩一个而且又能组成顺子的数
            ans=ans+book[i]/2;//处理对子
            book[i]=book[i]%2;
        }
        printf("%d\n",ans);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/sinat_40948489/article/details/80426842