Swap(二分图)

Given an N*N matrix with each entry equal to 0 or 1. You can swap any two rows or any two columns. Can you find a way to make all the diagonal entries equal to 1?

Input

There are several test cases in the input. The first line of each test case is an integer N (1 <= N <= 100). Then N lines follow, each contains N numbers (0 or 1), separating by space, indicating the N*N matrix.

Output

For each test case, the first line contain the number of swaps M. Then M lines follow, whose format is “R a b” or “C a b”, indicating swapping the row a and row b, or swapping the column a and column b. (1 <= a, b <= N). Any correct answer will be accepted, but M should be more than 1000.

If it is impossible to make all the diagonal entries equal to 1, output only one one containing “-1”.

Sample Input

2
0 1
1 0
2
1 0
1 0

Sample Output

1
R 1 2
-1
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N=111;
const int inf=0x3f3f3f3f;
int x[N],y[N],a[N][N],match[N],b[N];
int n;
int dfs(int x)
{
	for(int i=1; i<=n; i++)
		if(!b[i]&&a[x][i])
		{
			b[i]=1;
			if(!match[i]||dfs(match[i]))
			{
				match[i]=x;
				return 1;
			}
		}
	return 0;
}
int main()
{
	int i,j;
    /*
        while(1)
        {
            scanf("%d",&n);
        }//提交会超时
    
    */
	while(~scanf("%d",&n))
	{
		for(i=1; i<=n; i++)
			for(j=1; j<=n; j++)
				scanf("%d",&a[i][j]);
		memset(match,0,sizeof(int)*(n+4));
		int s=0;
		for(i=1; i<=n; i++)
		{
			memset(b,0,sizeof(int)*(n+4));
			if(dfs(i))
			s++;
		}
		if(s<n)
		{
			puts("-1");
			continue;
		}
		int k=0;
		for(i=1; i<=n; i++)
		{
			while(match[i]!=i)// 行列不对应,主对角线,列=行
			{
				x[k]=match[i];
				y[k++]=i;
				swap(match[i],match[match[i]]);
			}
		}
		printf("%d\n",k);
		for(i=0; i<k; i++)
			printf("C %d %d\n",y[i],x[i]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_52898168/article/details/120617854