#1080. Graduate Admission【模拟 + 排序】

原题链接

Problem Description:

It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade G E G_E GE, and the interview grade G I G_I GI. The final grade of an applicant is ( G E + G I ) / 2 (G_E + G_I)/2 (GE+GI)/2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G E G_E GE. If still tied, their ranks must be the same.

  • Each applicant may have K K K choices and the admission will be done according to his/her choices: if according to the rank list, it is one’s turn to be admitted; and if the quota of one’s most preferred school is not exceeded, then one will be admitted to this school, or one’s other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case.

Each case starts with a line containing three positive integers: N N N ( ≤ 40 , 000 \leq 40,000 40,000), the total number of applicants; M M M ( ≤ 100 \leq 100 100), the total number of graduate schools; and K K K ( ≤ 5 \leq 5 5), the number of choices an applicant may have.

In the next line, separated by a space, there are M M M positive integers. The i i i-th integer is the quota of the i i i-th graduate school respectively.

Then N N N lines follow, each contains 2 + K 2+K 2+K integers separated by a space. The first 2 integers are the applicant’s G E G_E GE and G I G_I GI, respectively. The next K K K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M − 1 M−1 M1, and the applicants are numbered from 0 to N − 1 N−1 N1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants’ numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:

0 10
3
5 6 7
2 8

1 4

Problem Analysis:

模拟题,注意这里可以不用记录每个人的具体排名,按顺序排列好,然后每次处理连续的一段(相同排名)即可。

Code

#include <iostream>
#include <algorithm>
#include <cstring>
#include <vector>

using namespace std;

const int N = 40010, M = 110, K = 5;

int n, m, k;
int cnt[M];
int wish[N];
vector<int> uty[M];

struct Person
{
    
    
    int id, ge, gi;
    int wish[K];

    int total() const
    {
    
    
        return ge + gi;
    }

    bool operator< (const Person &t) const
    {
    
    
        if (total() != t.total()) return total() > t.total();
        return ge > t.ge;
    }

    bool operator== (const Person &t) const 
    {
    
    
        return ge == t.ge && gi == t.gi;
    }
}p[N];

int main()
{
    
    
    scanf("%d%d%d", &n, &m, &k);

    for (int i = 0; i < m; i ++ ) scanf("%d", &cnt[i]);
    for (int i = 0; i < n; i ++ )
    {
    
    
        p[i].id = i;
        scanf("%d%d", &p[i].ge, &p[i].gi);

        for (int j = 0; j < k; j ++ )
            scanf("%d", &p[i].wish[j]);
    }

    sort(p, p + n); 

    memset(wish, -1, sizeof wish);
    for (int i = 0; i < n;)
    {
    
    
        int j = i + 1;
        while (j < n && p[i] == p[j]) j ++ ;

        for (int t = i; t < j; t ++ )
            for (int u = 0; u < k; u ++ )
            {
    
    
                int w = p[t].wish[u];
                if (cnt[w] > uty[w].size())
                {
    
    
                    wish[t] = w;
                    break;
                }
            }
        for (int t = i; t < j; t ++ )
            if (wish[t] != -1)
                uty[wish[t]].push_back(p[t].id);
        i = j;
    }

    for (int i = 0; i < m; i ++ )
    {
    
    
        if (uty[i].size())
        {
    
    
            sort(uty[i].begin(), uty[i].end());
            printf("%d", uty[i][0]);
            for (int j = 1; j < uty[i].size(); j ++ )
                printf(" %d", uty[i][j]);
        }
        puts("");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/geraltofrivia123/article/details/121304385