#1079. Total Sales of Supply Chain【树的遍历 + 记忆化搜索】

原题链接

Problem Description:

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P P P and sell or distribute them in a price that is r r r% higher than P P P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N N N ( ≤ 1 0 5 \leq 10^5 105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N − 1 N−1 N1, and the root supplier’s ID is 0); P P P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N N N lines follow, each describes a distributor or retailer in the following format:

K i K_i Ki ID[1] ID[2] … \ldots ID[ K i K_i Ki]

where in the i i i-th line, K i K_i Ki is the total number of distributors or retailers who receive products from supplier i i i, and is then followed by the ID’s of these distributors or retailers. K j K_j Kj being 0 means that the j j j-th member is a retailer, then instead the total amount of the product will be given after K j K_j Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1 0 10 10^{10} 1010.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

Problem Analysis:

根据题意,我们可以模拟样例如下:
在这里插入图片描述
可见,零售商表示叶子节点,每个零售商的售卖商品件数不同,并且售卖的价格取决于该叶子节点到根节点的距离,故总价格 res 表示为所有叶子节点的售价总额之和。

这里我们可以采用记忆化搜索的方式来计算每个节点到根节点的距离,这种方式不用存图,代码较为简洁。

Code

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

const int N = 100010;

int n; // 节点个数
double P, R; // 每件商品的售卖价格,R表示溢出比
int p[N], f[N], c[N]; // 每个节点的父节点,每个节点到根节点的距离,叶节点上卖出商品的数量

int dfs(int u)
{
    
    
    if (f[u] != -1) return f[u];
    // 为根节点
    if (p[u] == -1) return f[u] = 0;
    return f[u] = dfs(p[u]) + 1;
}

int main()
{
    
    
    cin >> n >> P >> R;
    
    memset(p, -1, sizeof p); 
    for (int i = 0; i < n; i ++ )
    {
    
    
        int k;
        cin >> k;
        for (int j = 0; j < k; j ++ )
        {
    
    
            int son;
            cin >> son;
            p[son] = i;
        }
        if (!k)  cin >> c[i];
    }
    
    memset(f, -1, sizeof f);
    
    double res = 0;
    
    for (int i = 0; i < n; i ++ )
        if (c[i])
            res += c[i] * P * pow(1 + R / 100, dfs(i));
    printf("%.1lf\n", res);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/geraltofrivia123/article/details/121023930