FZU 2188 过河Ⅰ ( 思维BFS 状态?

2188 过河Ⅰ

题目描述

一天,小明需要把x只羊和y只狼运输到河对面。船可以容纳n只动物和小明。每次小明划船时,都必须至少有一只动物来陪他,不然他会感到厌倦,不安。不论是船上还是岸上,狼的数量如果超过羊,狼就会把羊吃掉。小明需要把所有动物送到对面,且没有羊被吃掉,最少需要多少次他才可以穿过这条河?

输入

有多组数据,每组第一行输入3个整数想x, y, n (0≤ x, y,n ≤ 200)

输出

如果可以把所有动物都送过河,且没有羊死亡,则输出一个整数:最少的次数。 否则输出 -1 .

样例

Sample Input
3   3   2
33  33  3
Sample Output
11
-1

Hint
第一个样例

次数 船 方向 左岸 右岸(狼 羊)

0: 0 0 3 3 0 0

1: 2 0 > 1 3 2 0

2: 1 0 < 2 3 1 0

32 0 > 0 3 3 0

4: 1 0 < 1 3 2 0

50 2 > 1 1 2 2

6: 1 1 < 2 2 1 1

70 2 > 2 0 1 3

8: 1 0 < 3 0 0 3

92 0 > 1 0 2 3

10: 1 0 < 2 0 1 3

112 0 > 0 0 3 3

题意

这个题 明显的我们会发现是一个的 关于过河 河左边 河右边 三个点 一点都不明显
我们要寻找的是过河的每种状态
然后就是大量的剪枝 找到合适的状态扔进队列里面进行搜索了
剪枝的点:
1.船上必须有个动物且羊大于狼
2.两个河岸必须要符合羊大于狼的设定
3.船上羊狼的个数小于n

AC代码

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <cmath>
#include <cctype>
#include <string>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <ctime>
#include <vector>
#include <fstream>
#include <list>
#include <iomanip>
#include <numeric>
using namespace std;

#define ls              st<<1
#define rs              st<<1|1
#define fst             first
#define snd             second
#define MP              make_pair
#define PB              push_back
#define LL              long long
#define PII             pair<int,int>
#define VI              vector<int>
#define CLR(a,b)        memset(a, (b), sizeof(a))
#define ALL(x)          x.begin(),x.end()
#define rep(i,s,e) for(int i=(s); i<=(e); i++)
#define tep(i,s,e) for(int i=(s); i>=(e); i--)

const int INF = 0x3f3f3f3f;
const int MAXN = 2e2+10;
const int mod = 1e9+7;
const double eps = 1e-8;

void fe() {
  #ifndef ONLINE_JUDGE
      freopen("in.txt", "r", stdin);
      freopen("out.txt","w",stdout);
  #endif
}
LL read()
{
   LL x=0,f=1;char ch=getchar();
   while (ch<'0'||ch>'9') {if (ch=='-') f=-1;ch=getchar();}
   while (ch>='0'&&ch<='9') x=(x<<1)+(x<<3)+ch-'0',ch=getchar();
   return x*f;
}

int x, y, n;
bool vis[2][MAXN][MAXN];
struct node
{
    // st 为步数 v为当前状态(哪个河岸)
    int x, y, st, v;
    node(int _x=0, int _y=0, int _st=0, int _v=0):x(_x),y(_y),st(_st),v(_v){}
};
queue<node> que;
void bfs() {
    while(!que.empty()) que.pop();
    CLR(vis,false);
    que.push(node(x,y,0,0)); 
    vis[0][x][y] = true;
    while(!que.empty()) {
        node tmp = que.front();
        que.pop();
        if(tmp.x==x && tmp.y==y && tmp.v==1) {
            cout << tmp.st << endl;
            return ;
        }
        int xx = x-tmp.x, yy = y-tmp.y;
        for(int i = 0; i <= tmp.x; i++) {
            for(int j = 0; j <= tmp.y; j++) {
                if(i && i<j)
                    continue;
                if(i+j>n || i+j==0) 
                    continue;
                if((tmp.x-i!=0&&tmp.x-i<tmp.y-j) || (xx+i!=0&&xx+i<yy+j))
                    continue;
                int xxx = xx+i, yyy = yy+j, st = tmp.st+1, vv = tmp.v^1;
                if(!vis[vv][xxx][yyy]) {
                    vis[vv][xxx][yyy] = true;
                    que.push(node(xxx,yyy,st,vv));
                }
            }
        }
    }
    cout << -1 << endl;
}
int main(int argc, char const *argv[])
{
    while(cin >> x >> y >> n) {
        bfs();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wang2332/article/details/80585452