HDU 1158 Employment Planing (简单dp三重循环)

Employment Planning 
 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5955    Accepted Submission(s): 2571


Problem Description
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project.
 

Input
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single '0'.
 

Output
The output contains one line. The minimal total cost of the project.
 

Sample Input
 
  
3 4 5 610 9 110
 

Sample Output
 
  
199
 

Source
 

Recommend
Ignatius   |   We have carefully selected several similar problems for you:   1227  1074  1080  1024  1025 
#include <queue>
#include <iostream>
#include<cstring>
#include<stdio.h>
#define maxn 200050
#define MAX  1e9
using namespace std;
int n;
int hire,salary,fire;
int dp[15][maxn],x;
int seq[maxn],maxv;
int compute(int x)
{
    if(x<0) return (-x*fire);//+x*salary);
    return x*(salary+hire);
}
/*
理清关系即可,
注意解雇人时该月还要发工资
*/
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n&&n)
    {
        maxv=-1;
        cin>>hire>>salary>>fire;
        for(int i=1;i<=n;i++)
        {
            cin>>x;seq[i]=x;
            maxv=max(maxv,x);
        }
        for(int i=seq[1];i<=maxv;i++)  dp[1][i]=i*(salary+hire);
        for(int i=2;i<=n;i++)
        {
            for(int j=seq[i];j<=maxv;j++)
            {
                dp[i][j]=MAX;
                for(int k=seq[i-1];k<=maxv;k++)
                {
                    if(k<=j)   dp[i][j]=min(dp[i][j],dp[i-1][k]+j*salary+(j-k)*hire);
                    else   dp[i][j]=min(dp[i][j],dp[i-1][k]+j*salary+(k-j)*fire);
                }
            }
        }
        int ans=1<<30;
        for(int i=seq[n];i<=maxv;i++)
            ans=min(ans,dp[n][i]);
        cout<<ans<<endl;
    }
    return 0;
}

 
  

猜你喜欢

转载自blog.csdn.net/qq_37451344/article/details/80401424