day4 1042 Shuffling Machine (20)

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, H1, H2, ..., H13, C1, C2, ..., C13, D1, D2, ..., D13, J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

#include <cstdio>
const int N=54;
char mp[5]={'S','H','C','D','J'};
int start[N+1],end[N+1],next[N+1]; 
int main()
{
	int n;
	scanf("%d",&n);
	for(int i=1;i<=N;i++)
        start[i]=i;
	for(int i=1;i<=N;i++)
	    scanf("%d",&next[i]);
	while(n--)
	{
		for(int i=1;i<=N;i++)
		{
			end[next[i]]=start[i];
		}
	    for(int i=1;i<=N;i++)
	        start[i]=end[i];
	}
	for(int i=1;i<=N-1;i++)
    	printf("%c%d ",mp[(end[i]-1)/13],(end[i]-1)%13+1);
	printf("%c%d",mp[(end[N]-1)/13],(end[N]-1)%13+1);
	return 0;
}

又是按照书搬运的一题

和剪刀石头布类似 字符太麻烦存在数组里会比较方便 与剪刀石头布类似的是 用运算可以写出牌的序号(重要)

用三个数组start next end   start[顺序]=数值 end[顺序]=数值 next[数字]=顺序

start放刚开始的数值 序号为顺序 即1志54 next存放输入的变换信息 end放最终的信息并 将其赋给start进行下一次循环 这部分比较简单

输出部分 计算好花色和数字的对应关系

格式方面最后不应输出空格 既可用上面的方法

也可以先输出空格 第一个空格不输入;

有N个数 既然序号与数值有关  可以直接定义N+1维数组 第一个位置不用即可

第一个甲级题 

猜你喜欢

转载自blog.csdn.net/coding18/article/details/80762515