栈stack<int>s(先进后出)

Rails

Description

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track. 

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station. 

Input

The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0. 

The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No

Yes

题意:有一列火车,车厢编号为1到n,只能由一段进站,另一端出站。现在进站顺序确定:1,2,3,4...n,给出一个出站的顺序,判断出站顺序是否可能。

思路:其实就是一个模拟栈的过程,先进后出。但是由于会出现这样的情况,比如说:1 2 3进栈,然后3出栈,然后4 5进栈,所以该出栈的顺序是3 5 4 2 1,所以在模拟的过程中需要注意一下。

还有就是注意一下最后输入0的时候没有换行,所以需要特殊处理一下。

#include <cstdio>  
#include <stack>  
using namespace std;  
const int maxn=1000+5;  
int a[maxn];  
int main()  
{  
    int n,i,k;  
    while(scanf("%d",&n)&&n)  
    {  
        stack<int>s;//设立一个栈储存按顺序进栈的序列 (一个空栈)  
        while(scanf("%d",&a[0])&&a[0])  
        {  
            for(i=1;i<n;i++)  
                scanf("%d",&a[i]);//要进行判断出栈的序列  
            for(i=1,k=0;i<=n;i++)  
            {  
                s.push(i);//进栈  
                while(s.top()==a[k])//判断栈顶元素和a数组是否相等  
                {  
                    if(!s.empty()) s.pop();//栈不为空就出栈  
                    k++;//判断下一个位置  
                    if(s.empty()) break;//直到栈空就结束循环  
                }  
            }  
            if(k==n) printf("Yes\n");//完全匹配就输出yes  
           else printf("No\n");  
        }  
        printf("\n");  
    }  
    return 0;  
} 

猜你喜欢

转载自blog.csdn.net/luojiushenzi/article/details/80184144