二维RMQ_Check Corners_HDU - 2888

Check Corners

Paul draw a big m*n matrix A last month, whose entries Ai,j are all integer numbers ( 1 <= i <= m, 1 <= j <= n ). Now he selects some sub-matrices, hoping to find the maximum number. Then he finds that there may be more than one maximum number, he also wants to know the number of them. But soon he find that it is too complex, so he changes his mind, he just want to know whether there is a maximum at the four corners of the sub-matrix, he calls this “Check corners”. It’s a boring job when selecting too many sub-matrices, so he asks you for help. (For the “Check corners” part: If the sub-matrix has only one row or column just check the two endpoints. If the sub-matrix has only one entry just output “yes”.)

Input There are multiple test cases.

For each test case, the first line contains two integers m, n (1 <= m, n <= 300), which is the size of the row and column of the matrix, respectively. The next m lines with n integers each gives the elements of the matrix which fit in non-negative 32-bit integer.

The next line contains a single integer Q (1 <= Q <= 1,000,000), the number of queries. The next Q lines give one query on each line, with four integers r1, c1, r2, c2 (1 <= r1 <= r2 <= m, 1 <= c1 <= c2 <= n), which are the indices of the upper-left corner and lower-right corner of the sub-matrix in question.
Output For each test case, print Q lines with two numbers on each line, the required maximum integer and the result of the “Check corners” using “yes” or “no”. Separate the two parts with a single space. Sample Input
4 4
4 4 10 7
2 13 9 11
5 7 8 20
13 20 8 2
4
1 1 4 4
1 1 3 3
1 3 3 4
1 1 1 1
Sample Output
20 no
13 no
20 yes
4 yes
#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define all(x) begin(x),end(x)
ll rd(){
    ll x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}


//二维RMQ,预处理复杂度 n*m*log*(n)*log(m)
//数组下标从 1 开始

const int maxn=300+10;
const int max_log=9;
int val[maxn][maxn];
int dp[maxn][maxn][max_log][max_log];//最大值
int mm[maxn]; //二进制位数减一
void initRMQ(int n,int m)
{
    mm[0] = -1;
    for(int i = 1; i <= 305; i++)
        mm[i] = ((i&(i-1))==0)?mm[i-1]+1:mm[i-1];
    for(int i = 1; i <= n; i++)
        for(int j = 1; j <= m; j++){
            dp[i][j][0][0] = val[i][j];
        }

    for(int ii = 0; ii <= mm[n]; ii++)
        for(int jj = 0; jj <= mm[m]; jj++)
            if(ii+jj)
                for(int i = 1; i + (1<<ii) - 1 <= n; i++)
                for(int j = 1; j + (1<<jj) - 1 <= m; j++)
                {
                    if(ii){
                        dp[i][j][ii][jj]= max(dp[i][j][ii-1][jj],dp[i+(1<<(ii-1))][j][ii-1][jj]);
                    }
                    else{
                        dp[i][j][ii][jj]= max(dp[i][j][ii][jj-1],dp[i][j+(1<<(jj-1))][ii][jj-1]);
                    }
                }
}
//get Min x1<=x2,y1<=y2)
int rmq(int x1,int y1,int x2,int y2)
{
    int k1 = mm[x2-x1+1];
    int k2 = mm[y2-y1+1];
    x2 = x2 - (1<<k1) + 1;
    y2 = y2 - (1<<k2) + 1;
    return max(max(dp[x1][y1][k1][k2],
                dp[x1][y2][k1][k2])
               ,max(dp[x2][y1][k1][k2]
                ,dp[x2][y2][k1][k2]));
}

int main(){
    //freopen("in.txt","r",stdin);
    int n,m;
    while(~scanf("%d%d",&n,&m)){
        for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        val[i][j]=rd();
        initRMQ(n,m);
        int q=rd();
        while(q--){
            int a=rd(),b=rd(),c=rd(),d=rd();
            int ans=rmq(a,b,c,d);
            bool f=false;
            if(val[a][b]==ans||val[c][d]==ans||val[c][b]==ans||val[a][d]==ans)
                f=true;
            printf("%d %s\n",ans,f?"yes":"no");
        }
    }
}


猜你喜欢

转载自blog.csdn.net/ujn20161222/article/details/80181230