[kuangbin带你飞]专题一 简单搜索 E - Find The Multiple

E - Find The Multiple

 

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111

//让你输出一个1和0表示的数,要求这个数是n的倍数
//从1开始,每次走的方法要么是10*x||10*x+1

#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
queue <long long> q;
int n;
void bfs(long long x)
{
    while(!q.empty())
    {
        long long x=q.front();
        q.pop();
        if(x%n!=0)
        {
            q.push(x*10);
            q.push(x*10+1);
        }
        else
        {
            printf("%lld\n",x);
            return;
        }
    }
}
int main()
{
    while(cin>>n)
    {
        while(!q.empty()) q.pop();
        if(n>0)
        {
            q.push(1);
            bfs(1);
        }
        else
            return 0;
    }

}


猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/80941406