7.5 ZUFEOJ--B 小数次方java模板

问题 B: 乾隆巡江南

时间限制: 2 Sec   内存限制: 128 MB
提交: 9   解决: 5
[ 提交][ 状态][ 讨论版][命题人: 外部导入]

题目描述

        话说乾隆带着他的宰相刘罗锅和你出巡江南,被杭州城府邀请去听戏,至于什么戏,那就不知了。乾隆很高兴,撒酒与君臣共享。三更欲回住处,可是乾隆这人挺怪,他首先要到西湖边散散步,而且命令不准有人跟着他。         小醉,步于西湖岸,停于断桥前,突闻琴声悠悠,歌儿婉婉。这乐曲不哀伤不愁怅,少了一分怨女的羁绊,多了一分少女的期盼。乾隆走上前去,视其背影,为一女子手抚古琴,悠悠而唱。可是这么晚了,小女怎么还不回家呢,莫非是她起早床?乾隆走上前去,小声问道:“伊为何未宿?”,小女沉默片刻,转身而来。顿时,顿时,顿时!!!!!乾隆惊呆了!!!!哇!!!!噻!!!!!!这人,这伊!!!!原来!!!!!!!不是一个美女(狂汗ing)。小女并未回答她的话,只是与乾隆侃了侃诗。乾隆兴哉,问其曰:“不知偶能助伊否?”,小女曰:“偶无所以助,且有一事相求,愿君能解之。”         乾隆一看,立刻晕到在地,片刻而起,曰:“明日必解之”,且去。         回到家中,乾隆夜召你“入寝”,曰:“如此姑娘,如此情调,如此罗曼蒂克,竟然丢一个如此煞风景之问”,一边发气,一边把这个问题交给你。你一看,顿然发现,原来是用蝌蚪文写的:         Problems  involving  the  computation  of  exact  values  of  very  large  magnitude  and  precision  are  common.  For  example,  the  computation  of  the  national  debt  is  a  taxing  experience  for  many  computer  systems.          This  problem  requires  that  you  write  a  program  to  compute  the  exact  value  of  Rn  where  R  is  a  real  number  (  0.0  <   R  < =  9999.9)  and  n  is  an  integer  such  that  0  <   n  < =  200.          此时的你,已经是皇帝身边的小太监,自然有必要为皇上解决此题。

输入

        The  input  will  consist  of  a  set  (less  than  11)  of  pairs  of  values  for  R  and  n.  The  R  value  will  occupy  columns  1  through  6,  and  the  n  value  will  be  in  columns  8  and  9.

输出

        The  output  will  consist  of  one  line  for  each  line  of  input  giving  the  exact  value  of  R^n.  Leading  zeros  should  be  suppressed  in  the  output.  Insignificant  trailing  zeros  must  not  be  printed.  Don't  print  the  decimal  point  if  the  result  is  an  integer.

样例输入

95.123  2

0.4321  5
5.1234  7
6.7592  3
98.999  5
1.0100 10

样例输出

9048.385129

.01506334182914325601

92663.3181348508776705891407804544

308.806114738688

9509420210.697891990494999

1.10462212541120451001


JAVA  小数次方模板

import java.io.*;
import java.math.BigDecimal;
import java.util.*;
public class Main {
 
	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		while(cin.hasNextBigDecimal())
		{
			BigDecimal ans = cin.nextBigDecimal();
			int n=cin.nextInt();
			
		    	String res = ans.pow(n).stripTrailingZeros().toPlainString();//整数去掉小数点+后面的0
	           	 if(res.startsWith("0")) //去掉前导0  
	                {  
	                   res = res.substring(1);  
	                }  
	                System.out.println(res); 
		}
	}
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/80935059
7.5