POJ1563 HDU1302 ZOJ1710 UVA573 UVALive5318 The Snail【模拟】

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 2016   Accepted: 960

Description

A snail is at the bottom of a 6-foot well and wants to climb to the top. The snail can climb 3 feet while the sun is up, but slides down 1 foot at night while sleeping. The snail has a fatigue factor of 10%, which means that on each successive day the snail climbs 10% * 3 = 0.3 feet less than it did the previous day. (The distance lost to fatigue is always 10% of the first day's climbing distance.) On what day does the snail leave the well, i.e., what is the first day during which the snail's height exceeds 6 feet? (A day consists of a period of sunlight followed by a period of darkness.) As you can see from the following table, the snail leaves the well during the third day.  
Day    Initial Height    Distance Climbed    Height After Climbing    Height After Sliding 

 1            0'                 3'                    3'                       2'         

 2            2'                2.7'                  4.7'                     3.7'        

 3           3.7'               2.4'                  6.1'                      -          


Your job is to solve this problem in general. Depending on the parameters of the problem, the snail will eventually either leave the well or slide back to the bottom of the well. (In other words, the snail's height will exceed the height of the well or become negative.) You must find out which happens first and on what day.  

Input

The input contains one or more test cases, each on a line by itself. Each line contains four integers H, U, D, and F, separated by a single space. If H = 0 it signals the end of the input; otherwise, all four numbers will be between 1 and 100, inclusive. H is the height of the well in feet, U is the distance in feet that the snail can climb during the day, D is the distance in feet that the snail slides down during the night, and F is the fatigue factor expressed as a percentage. The snail never climbs a negative distance. If the fatigue factor drops the snail's climbing distance below zero, the snail does not climb at all that day. Regardless of how far the snail climbed, it always slides D feet at night.

Output

For each test case, output a line indicating whether the snail succeeded (left the well) or failed (slid back to the bottom) and on what day. Format the output exactly as shown in the example.

Sample Input

6 3 1 10
10 2 1 50
50 5 3 14
50 6 4 1
50 6 3 1
1 1 1 1
0 0 0 0

Sample Output

success on day 3
failure on day 4
failure on day 7
failure on day 68
success on day 20
failure on day 2

Source


Regionals 1997 >> North America - Mid-Central USA


问题链接POJ1563 HDU1302 ZOJ1710 UVA573 UVALive5318 The Snail

问题描述

扫描二维码关注公众号,回复: 2066597 查看本文章

  蜗牛每天都在爬,每个白天向上爬U距离,每个晚上下降D距离,而且每天爬的距离在不断减少,求几天后能够到达U的高度?或者几天后失败?

问题分析

  简单模拟题,不解释。

程序说明:(略)

参考链接:(略)

题记(略)


AC的C++语言程序如下:

/* POJ1563 HDU1302 ZOJ1710 UVA573 UVALive5318 The Snail */

#include <iostream>
#include <stdio.h>

using namespace std;

int main()
{
    int H, D, F;
    float U;
    while(~scanf("%d%f%d%d", &H, &U, &D, &F) && H) {
        int day = 0;
        float dist = 0;
        float f = F * 0.01 * U;
        for(;;) {
            dist += U;
            if(dist > H) {
                printf("success on day %d\n", day + 1);
                break;
            }

            dist -= D;
            if(dist < 0) {
                printf("failure on day %d\n",day + 1);
                break;
            }

            U -= f;
            if(U < 0)
                U = 0; // 蜗牛爬的距离不可能为负
            day++;
        }
    }    return 0;
}






猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/80892783