HDU 2609 最小表示法加how many

How many

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3649    Accepted Submission(s): 1645


Problem Description
Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some).
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110.
 

Input
The input contains multiple test cases.
Each test case include: first one integers n. (2<=n<=10000)
Next n lines follow. Each line has a equal length character string. (string only include '0','1').
 

Output
For each test case output a integer , how many different necklaces.
 

Sample Input
 
  
4 0110 1100 1001 0011 4 1010 0101 1000 0001
 

Sample Output
 
  
1 2
 

Author
yifenfei
 

Source
 

Recommend

yifenfei   |   We have carefully selected several similar problems for you:  2608 2612 1131 2572 1130 


#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <set>
using namespace std;
#define dbg(x) cout<<#x<<" = "<< (x)<< endl
const int MAX_N = 1000024;
int getmin(string s){
    int i = 0,j = 1,l=0;
    int len = s.length();
    while(i<len&&j<len){
        for(l=0;l<len;++l)
        if(s[(i+l)%len]!=s[(j+l)%len]) break;
        if(l>=len) break;
        if(s[(i+l)%len]>s[(j+l)%len]){
            if(i+l+1>j) i = i+l+1;
            else i = j+1;
        }
        else if(j+l+1>l) j = j + l +1;
        else j = i +1;
    }
    return i < j ?i:j;
}
int main(){
    int n;
    set<string> st;
    while(cin>>n){
    while(n--){
        string str_;
        string ans;
        cin>>str_;
        //printf("%s\n",str_.c_str());
        int len = str_.length();
        int t = getmin(str_);
        //dbg(t);
        ans=str_.substr(t,len-t)+str_.substr(0,t);
        //dbg(ans);
        //dbg(str_.substr(0,t));
        //printf("%s\n",ans.c_str());
        //dbg(ans);
        st.insert(ans);
    }
    cout << st.size() << endl;
    st.clear();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/heucodesong/article/details/80991379