POJ 2406 KMP Next数组性质水过

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 56055   Accepted: 23310

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

Waterloo local 2002.07.01

这类题遇到蛮多次了 要提醒自己 如果它不是正好一个周期串 要直接输出1

这需要特判 其他就是用循环长度利用n2-Next[n2]实现

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
#define dbg(x) cout<<#x<<" = "<< (x)<< endl
const int MAX_N = 1000024;
int Next[MAX_N];
char mo[MAX_N];
int n2;
void getnext(){
   int i=0,j=-1;
   while(i<n2){
    if(j==-1||mo[i]==mo[j]){++i,++j,Next[i] = j;}
    else j=Next[j];
   }
   return;
}
int main(){
    while(~scanf("%s",mo)){
        if(mo[0]=='.') break;
        memset(Next,0,sizeof(Next));
        n2 = strlen(mo);
        Next[0] = -1;
        getnext();
        if(n2%(n2-Next[n2])==0)
        printf("%d\n",n2/(n2-Next[n2]));
        else printf("1\n");

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/heucodesong/article/details/80808976