[带权并查集] [kuangbin带你飞]专题五 并查集 D - How Many Answers Are Wrong

D - How Many Answers Are Wrong

 


TT and FF are ... friends. Uh... very very good friends -________-b 

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored). 

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers. 

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose. 

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence. 

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed. 

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers. 

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy) 
InputLine 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions. 

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N. 

You can assume that any sum of subsequence is fit in 32-bit integer. 
OutputA single line with a integer denotes how many answers are wrong.Sample Input
10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1
Sample Output
1

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=2e5+5;
int pre[maxn],val[maxn],n,m,ans,u,v,w;
void init()  //初始化
{
    for(int i=0;i<=n;i++)
    {
        pre[i]=i;
        val[i]=0;
    }
}
int find(int x)  //路径压缩,更新值
{
    if(pre[x]==x) return x;
    int tt=find(pre[x]);
    val[x]+=val[pre[x]]; //递归找到祖先,回溯的时候加上自己爸爸的值
    return pre[x]=tt;   //然后把爸爸变成祖先,如果用正常的写法,会不停加上祖先的值
}
void join(int x,int y)
{
    int fx=find(x),fy=find(y);
    if(fx!=fy)
    {
        pre[fy]=fx;              //维护的是右边的边界
        val[fy]=val[u]-val[v]+w; //val[]基本可以说是从小到大
    }
    else
    {
        if(val[v]-val[u]!=w) ans++;  //所以真正计算时是val[v]-val[u]
    }
}
void print()
{
    for(int i=0;i<=n;i++)
        cout<<i<<" "<<pre[i]<<" "<<val[i]<<endl;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        ans=0;
        init();
        while(m--)
        {
            scanf("%d%d%d",&u,&v,&w);
            u--;//重点!!
            join(u,v);
           // print();
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/81051470